Kotlin 1.4 加强了 类型推导 和 实现了 Kotlin interface 的 ASM 转换功能。

然后大家可能会遇到一些问题比如 IDE 报错,但是程序还能照常运行。或者其他 Kotlin 相关的问题

排查问题

  1. 检查 build.gradle 中 kotlin-gradle-plugin 插件的版本。
  2. 检查依赖的 Kotlin 版本。
  3. 检查 Android Studio 的 Kotlin 插件版本。

2020-08-28T09:38:44.png

如果你会出现莫名其妙的问题,我相信你前两步肯定升级过了。

解决问题

  1. 找到 Android Studio 的相关设置

2020-08-28T09:41:09.png

如果你有问题这个地方会有新版本的提示,升级插件并重启就可以解决问题。
如果你还想用预览版插件在 Update channel 那一栏自行选择。